Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. openexr
  4. ›
  5. CVE-2021-20300

CVE-2021-20300: Integer Overflow or Wraparound

March 4, 2022 (updated December 13, 2022)

A flaw was found in OpenEXR’s hufUncompress functionality in OpenEXR/IlmImf/ImfHuf.cpp. This flaw allows an attacker who can submit a crafted file that is processed by OpenEXR, to trigger an integer overflow. The highest threat from this vulnerability is to system availability.

References

  • bugs.chromium.org/p/oss-fuzz/issues/detail?id=25562
  • bugzilla.redhat.com/show_bug.cgi?id=1939153
  • github.com/AcademySoftwareFoundation/openexr/pull/836
  • nvd.nist.gov/vuln/detail/CVE-2021-20300

Code Behaviors & Features

Detect and mitigate CVE-2021-20300 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.5.4

Fixed versions

  • 2.5.4

Solution

Upgrade to version 2.5.4 or above.

Impact 5.5 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-190: Integer Overflow or Wraparound

Source file

conan/openexr/CVE-2021-20300.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.