Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. nettle
  4. ›
  5. CVE-2021-3580

CVE-2021-3580: Improper Input Validation

August 5, 2021 (updated January 16, 2024)

A flaw was found in the way nettle’s RSA decryption functions handled specially crafted ciphertext. An attacker could use this flaw to provide a manipulated ciphertext leading to application crash and denial of service.

References

  • bugzilla.redhat.com/show_bug.cgi?id=1967983
  • nvd.nist.gov/vuln/detail/CVE-2021-3580

Code Behaviors & Features

Detect and mitigate CVE-2021-3580 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.7.3

Fixed versions

  • 3.7.3

Solution

Upgrade to version 3.7.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

conan/nettle/CVE-2021-3580.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:34 +0000.