Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. libressl
  4. ›
  5. CVE-2021-46880

CVE-2021-46880: Improper Certificate Validation

April 15, 2023 (updated May 17, 2023)

x509/x509_verify.c in LibreSSL before 3.4.2, and OpenBSD before 7.0 errata 006, allows authentication bypass because an error for an unverified certificate chain is sometimes discarded.

References

  • ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.4.2-relnotes.txt
  • ftp.openbsd.org/pub/OpenBSD/patches/7.0/common/006_x509.patch.sig
  • github.com/openbsd/src/commit/3f851282810fa0ab4b90b3b1ecec2e8717ef16f8
  • nvd.nist.gov/vuln/detail/CVE-2021-46880

Code Behaviors & Features

Detect and mitigate CVE-2021-46880 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.4.2

Fixed versions

  • 3.4.2

Solution

Upgrade to version 3.4.2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

conan/libressl/CVE-2021-46880.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:38 +0000.