Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. libcurl
  4. ›
  5. CVE-2023-27536

CVE-2023-27536: Improper Authentication

March 30, 2023 (updated November 7, 2023)

An authentication bypass vulnerability exists libcurl <8.0.0 in the connection reuse feature which can reuse previously established connections with incorrect user permissions due to a failure to check for changes in the CURLOPT_GSSAPI_DELEGATION option. This vulnerability affects krb5/kerberos/negotiate/GSSAPI transfers and could potentially result in unauthorized access to sensitive information. The safest option is to not reuse connections if the CURLOPT_GSSAPI_DELEGATION option has been changed.

References

  • hackerone.com/reports/1895135
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/36NBD5YLJXXEDZLDGNFCERWRYJQ6LAQW/
  • nvd.nist.gov/vuln/detail/CVE-2023-27536

Code Behaviors & Features

Detect and mitigate CVE-2023-27536 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.22.0 up to 7.88.1

Fixed versions

  • 8.0.1

Solution

Upgrade to version 8.0.1 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

conan/libcurl/CVE-2023-27536.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.