Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. glib
  4. ›
  5. CVE-2023-32643

CVE-2023-32643: Out-of-bounds Write

September 14, 2023 (updated September 20, 2023)

A flaw was found in GLib. The GVariant deserialization code is vulnerable to a heap buffer overflow introduced by the fix for CVE-2023-32665. This bug does not affect any released version of GLib, but does affect GLib distributors who followed the guidance of GLib developers to backport the initial fix for CVE-2023-32665.

References

  • gitlab.gnome.org/GNOME/glib/-/issues/2840
  • https://discourse.gnome.org/t/multiple-fixes-for-gvariant-normalisation-issues-in-glib/12835
  • nvd.nist.gov/vuln/detail/CVE-2023-32643

Code Behaviors & Features

Detect and mitigate CVE-2023-32643 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.75.1

Fixed versions

  • 2.75.1

Solution

Upgrade to version 2.75.1 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-787: Out-of-bounds Write

Source file

conan/glib/CVE-2023-32643.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:40 +0000.