Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. zendframework/zend-crypt
  4. ›
  5. CVE-2015-7503

CVE-2015-7503: Potential Information Disclosure in Zend\Crypt\PublicKey\Rsa\PublicKey

October 10, 2017 (updated November 5, 2017)

Zend\Crypt\PublicKey\Rsa\PublicKey has a call to openssl_public_encrypt() which uses PHP’s default $padding argument, which specifies OPENSSL_PKCS1_PADDING, indicating usage of PKCS1v1.5 padding. This padding has a known vulnerability, the Bleichenbacher’s chosen-ciphertext attack, which can be used to decrypt arbitrary ciphertexts. Users should upgrade to a fixed version unless there are not using the RSA public key functionality.

References

  • framework.zend.com/security/advisory/ZF2015-10

Code Behaviors & Features

Detect and mitigate CVE-2015-7503 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.4.9, all versions starting from 2.5.0 before 2.5.2

Fixed versions

  • 2.4.9
  • 2.5.2

Solution

Upgrade to versions 2.4.9, 2.5.2 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-320

Source file

packagist/zendframework/zend-crypt/CVE-2015-7503.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:29 +0000.