Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. yiisoft/yii2-dev
  4. ›
  5. CVE-2022-41922

CVE-2022-41922: Deserialization of Untrusted Data

November 23, 2022 (updated November 30, 2022)

yiisoft/yii before version 1.1.27 is vulnerable to Remote Code Execution (RCE) if the application calls unserialize() on arbitrary user input. This has been patched in 1.1.27.

References

  • github.com/yiisoft/yii/commit/ed67b7cc57216557c5c595c6650cdd2d3aa41c52
  • github.com/yiisoft/yii/security/advisories/GHSA-442f-wcwq-fpcf
  • nvd.nist.gov/vuln/detail/CVE-2022-41922

Code Behaviors & Features

Detect and mitigate CVE-2022-41922 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.27

Fixed versions

  • 2.0.0

Solution

Upgrade to version 2.0.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

packagist/yiisoft/yii2-dev/CVE-2022-41922.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:06 +0000.