Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. yiisoft/yii
  4. ›
  5. CVE-2025-32027

CVE-2025-32027: Yii does not prevent XSS in scenarios where fallback error renderer is used

April 11, 2025

Affected versions of yiisoft/yii are vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used.

References

  • github.com/advisories/GHSA-7r2v-8wxr-3ch5
  • github.com/yiisoft/yii
  • github.com/yiisoft/yii/commit/d386d737861c9014269b7ed8c36c65eadb387368
  • github.com/yiisoft/yii/security/advisories/GHSA-7r2v-8wxr-3ch5
  • nvd.nist.gov/vuln/detail/CVE-2025-32027

Code Behaviors & Features

Detect and mitigate CVE-2025-32027 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.31

Fixed versions

  • 1.1.31

Solution

Upgrade to version 1.1.31 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/yiisoft/yii/CVE-2025-32027.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.