Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. typo3/cms
  4. ›
  5. TYPO3-CORE-SA-2016-021

TYPO3-CORE-SA-2016-021: Cross-Site Scripting

September 13, 2016

Failing to properly encode user input, the page module is vulnerable to Cross-Site Scripting. A valid backend user account with permissions to edit plugins is needed to exploit this vulnerability.

References

  • typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2016-021

Code Behaviors & Features

Detect and mitigate TYPO3-CORE-SA-2016-021 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 6.2.27, all versions starting from 7.0.0.alpha before 7.6.11, all versions starting from 8.0.0.alpha before 8.3.1

Fixed versions

  • 6.2.27
  • 7.6.11
  • 8.3.1

Solution

Upgrade to versions 6.2.27, 7.6.11, 8.3.1 or above.

Source file

packagist/typo3/cms/TYPO3-CORE-SA-2016-021.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.