Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. typo3/cms
  4. ›
  5. GHSA-p5c5-gmj4-g48f

GHSA-p5c5-gmj4-g48f: Cross-Site Scripting (XSS) vulnerability in typolinks

June 5, 2024

All link fields within the TYPO3 installation are vulnerable to Cross-Site Scripting as authorized editors can insert data commands by using the url scheme “data:”.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/2016-07-19-5.yaml
  • github.com/TYPO3/typo3
  • github.com/advisories/GHSA-p5c5-gmj4-g48f
  • typo3.org/security/advisory/typo3-core-sa-2016-018

Code Behaviors & Features

Detect and mitigate GHSA-p5c5-gmj4-g48f with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 6.2.0 before 6.2.26, all versions starting from 7.6.0 before 7.6.10, all versions starting from 8.0.0 before 8.2.1

Fixed versions

  • 6.2.26
  • 7.6.10
  • 8.2.1

Solution

Upgrade to versions 6.2.26, 7.6.10, 8.2.1 or above.

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/typo3/cms/GHSA-p5c5-gmj4-g48f.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.