Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. typo3/cms
  4. ›
  5. CVE-2011-4628

CVE-2011-4628: Improper Authentication

April 22, 2022 (updated January 12, 2024)

TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to bypass authentication mechanisms in the backend through a crafted request.

References

  • github.com/advisories/GHSA-79gv-5cgx-x6rx
  • nvd.nist.gov/vuln/detail/CVE-2011-4628
  • security-tracker.debian.org/tracker/CVE-2011-4628
  • typo3.org/security/advisory/typo3-core-sa-2011-001/

Code Behaviors & Features

Detect and mitigate CVE-2011-4628 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.3.12, all versions starting from 4.4.0 before 4.4.9, all versions starting from 4.5.0 before 4.5.4

Fixed versions

  • 4.3.12
  • 4.4.9
  • 4.5.4

Solution

Upgrade to versions 4.3.12, 4.4.9, 4.5.4 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

packagist/typo3/cms/CVE-2011-4628.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:35 +0000.