Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. thorsten/phpmyfaq
  4. ›
  5. CVE-2025-62519

CVE-2025-62519: phpMyFAQ has Authenticated SQL Injection in Configuration Update Functionality

November 17, 2025

An authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ (v4.0.13 and prior) allows a privileged user with ‘Configuration Edit’ permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration.

References

  • github.com/advisories/GHSA-fxm2-cmwj-qvx4
  • github.com/thorsten/phpMyFAQ
  • github.com/thorsten/phpMyFAQ/compare/4.0.13...4.0.14
  • github.com/thorsten/phpMyFAQ/security/advisories/GHSA-fxm2-cmwj-qvx4
  • nvd.nist.gov/vuln/detail/CVE-2025-62519

Code Behaviors & Features

Detect and mitigate CVE-2025-62519 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.0.14

Fixed versions

  • 4.0.14

Solution

Upgrade to version 4.0.14 or above.

Impact 7.2 HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Source file

packagist/thorsten/phpmyfaq/CVE-2025-62519.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.