Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. thorsten/phpmyfaq
  4. ›
  5. CVE-2023-1887

CVE-2023-1887: thorsten/phpmyfaq vulnerable to business logic errors

April 5, 2023 (updated April 6, 2023)

Business Logic Errors in GitHub repository thorsten/phpmyfaq prior to 3.1.12.

References

  • github.com/advisories/GHSA-gx43-fqrx-6fcw
  • github.com/thorsten/phpmyfaq/commit/400d9cd988d3287515c56b2ad6343026966f1a89
  • huntr.dev/bounties/e4a58835-96b5-412c-a17e-3ceed30231e1
  • nvd.nist.gov/vuln/detail/CVE-2023-1887

Code Behaviors & Features

Detect and mitigate CVE-2023-1887 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.12

Fixed versions

  • 3.1.12

Solution

Upgrade to version 3.1.12 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-840

Source file

packagist/thorsten/phpmyfaq/CVE-2023-1887.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:02 +0000.