Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. thorsten/phpmyfaq
  4. ›
  5. CVE-2023-1754

CVE-2023-1754: Improper Input Validation

March 31, 2023

Improper Input Validation in GitHub repository thorsten/phpmyfaq prior to 3.1.12.

References

  • github.com/advisories/GHSA-gvg8-r8w2-9gfj
  • github.com/thorsten/phpmyfaq/commit/d773df925cb74e874527458beed1f66f966ec491
  • huntr.dev/bounties/529f2361-eb2e-476f-b7ef-4e561a712e28
  • nvd.nist.gov/vuln/detail/CVE-2023-1754

Code Behaviors & Features

Detect and mitigate CVE-2023-1754 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.12

Fixed versions

  • 3.1.12

Solution

Upgrade to version 3.1.12 or above.

Impact 4.7 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

packagist/thorsten/phpmyfaq/CVE-2023-1754.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:18 +0000.