Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. thorsten/phpmyfaq
  4. ›
  5. CVE-2022-3766

CVE-2022-3766: phpMyFAQ vulnerable to reflected Cross-site Scripting

October 31, 2022 (updated February 18, 2026)

phpMyFAQ prior to version 3.1.8 is vulnerable to reflected cross-site scripting.

References

  • github.com/MarkLee131/awesome-web-pocs/blob/main/CVE-2022-3766.md
  • github.com/advisories/GHSA-mg5h-rhjq-6v84
  • github.com/thorsten/phpmyfaq
  • github.com/thorsten/phpmyfaq/commit/c7904f2236c6c0dd64c2226b90c30af0f7e5a72d
  • huntr.dev/bounties/d9666520-4ff5-43bb-aacf-50c8e5570983
  • nvd.nist.gov/vuln/detail/CVE-2022-3766

Code Behaviors & Features

Detect and mitigate CVE-2022-3766 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.8

Fixed versions

  • 3.1.8

Solution

Upgrade to version 3.1.8 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/thorsten/phpmyfaq/CVE-2022-3766.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:52 +0000.