Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. thorsten/phpmyfaq
  4. ›
  5. CVE-2022-3765

CVE-2022-3765: phpMyFAQ vulnerable to stored Cross-site Scripting

October 31, 2022

Cross-site Scripting (XSS) - Stored in GitHub repository thorsten/phpmyfaq prior to 3.1.8.

References

  • github.com/advisories/GHSA-wr74-2v66-57pp
  • github.com/thorsten/phpmyfaq/commit/372428d02a08e90b3a253ba5c506cda84581a5af
  • huntr.dev/bounties/613143a1-8e51-449a-b214-12458308835d
  • nvd.nist.gov/vuln/detail/CVE-2022-3765

Code Behaviors & Features

Detect and mitigate CVE-2022-3765 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.8

Fixed versions

  • 3.1.8

Solution

Upgrade to version 3.1.8 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Source file

packagist/thorsten/phpmyfaq/CVE-2022-3765.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:44 +0000.