Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. thorsten/phpmyfaq
  4. ›
  5. CVE-2022-3754

CVE-2022-3754: Weak Password Requirements

October 29, 2022 (updated October 31, 2022)

Weak Password Requirements in GitHub repository thorsten/phpmyfaq prior to 3.1.8.

References

  • github.com/advisories/GHSA-2rr3-rv49-p42f
  • github.com/thorsten/phpmyfaq/commit/d7a87d2646287828c70401ca8976ef531fbc77ea
  • huntr.dev/bounties/f4711d7f-1368-48ab-9bef-45f32e356c47
  • nvd.nist.gov/vuln/detail/CVE-2022-3754

Code Behaviors & Features

Detect and mitigate CVE-2022-3754 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.8

Fixed versions

  • 3.1.8

Solution

Upgrade to version 3.1.8 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-521: Weak Password Requirements

Source file

packagist/thorsten/phpmyfaq/CVE-2022-3754.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.