Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. thelia/backoffice-default-template
  4. ›
  5. GHSA-pp7v-wxx9-hm6r

GHSA-pp7v-wxx9-hm6r: Thelia BackOffice default template vulnerable to Cross-site Scripting

May 30, 2024

The BackOffice of Thelia (error.html template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/thelia/backoffice-default-template/2015-02-24-1.yaml
  • github.com/advisories/GHSA-pp7v-wxx9-hm6r
  • github.com/thelia-templates/back
  • github.com/thelia-templates/back/commit/592612899057addc2613ccddf172024588277d2d
  • thelia.net/version-2-1-2-with-security-fix
  • web.archive.org/web/20160406004324/http://thelia.net/version-2-1-2-with-security-fix

Code Behaviors & Features

Detect and mitigate GHSA-pp7v-wxx9-hm6r with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.1.0 before 2.1.2

Fixed versions

  • 2.1.2

Solution

Upgrade to version 2.1.2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/thelia/backoffice-default-template/GHSA-pp7v-wxx9-hm6r.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.