Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. spip/spip
  4. ›
  5. CVE-2019-11071

CVE-2019-11071: Improper Input Validation

April 10, 2019 (updated May 2, 2019)

SPIP allows authenticated visitors to execute arbitrary code on the host server because var_memotri is mishandled.

References

  • blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-Sortie-de-SPIP-3-1-10-et-SPIP-3-2-4.html
  • nvd.nist.gov/vuln/detail/CVE-2019-11071

Code Behaviors & Features

Detect and mitigate CVE-2019-11071 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.1.0 before 3.1.10, all versions starting from 3.2.0 before 3.2.4

Fixed versions

  • 3.1.10
  • 3.2.4

Solution

Upgrade to versions 3.1.10, 3.2.4 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

packagist/spip/spip/CVE-2019-11071.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.