Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. snipe/snipe-it
  4. ›
  5. CVE-2025-65621

CVE-2025-65621: Snipe-IT is vulnerable to stored cross-site scripting

December 1, 2025 (updated December 4, 2025)

Snipe-IT before 8.3.4 allows stored XSS, allowing a low-privileged authenticated user to inject JavaScript that executes in an administrator’s session, enabling privilege escalation.

References

  • github.com/advisories/GHSA-fww5-m9wc-jcjc
  • github.com/firef0x00/vulnerability-research/tree/main/CVE-2025-65621
  • github.com/grokability/snipe-it
  • github.com/grokability/snipe-it/releases/tag/v8.3.4
  • nvd.nist.gov/vuln/detail/CVE-2025-65621

Code Behaviors & Features

Detect and mitigate CVE-2025-65621 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.3.4

Fixed versions

  • 8.3.4

Solution

Upgrade to version 8.3.4 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/snipe/snipe-it/CVE-2025-65621.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.