Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. snipe/snipe-it
  4. ›
  5. CVE-2025-59713

CVE-2025-59713: Snipe-IT allows unsafe deserialization

September 19, 2025

Snipe-IT before 8.1.18 allows unsafe deserialization.

References

  • github.com/advisories/GHSA-phwj-fgch-xvrj
  • github.com/grokability/snipe-it
  • github.com/grokability/snipe-it/releases/tag/v8.1.18
  • nvd.nist.gov/vuln/detail/CVE-2025-59713

Code Behaviors & Features

Detect and mitigate CVE-2025-59713 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.1.18

Fixed versions

  • 8.1.18

Solution

Upgrade to version 8.1.18 or above.

Impact 6.8 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

packagist/snipe/snipe-it/CVE-2025-59713.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:50 +0000.