Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. snipe/snipe-it
  4. ›
  5. CVE-2022-44380

CVE-2022-44380: Snipe-IT vulnerable to Cross Site Scripting for View Assigned Assets

December 25, 2022 (updated April 15, 2025)

Snipe-IT before 6.0.14 is vulnerable to Cross Site Scripting (XSS) for View Assigned Assets.

References

  • census-labs.com/news/2022/12/23/multiple-vulnerabilities-in-snipe-it
  • github.com/advisories/GHSA-363q-j92x-7543
  • github.com/snipe/snipe-it
  • nvd.nist.gov/vuln/detail/CVE-2022-44380

Code Behaviors & Features

Detect and mitigate CVE-2022-44380 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 6.0.14

Fixed versions

  • 6.0.14

Solution

Upgrade to version 6.0.14 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/snipe/snipe-it/CVE-2022-44380.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:17 +0000.