Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. snipe/snipe-it
  4. ›
  5. CVE-2022-3173

CVE-2022-3173: Improper Authentication

September 17, 2022 (updated September 21, 2022)

Improper Authentication in GitHub repository snipe/snipe-it prior to 6.0.10.

References

  • github.com/snipe/snipe-it/commit/dcab1381e7ee0b7fd1df3a34750dbff4b79185b2
  • huntr.dev/bounties/6d8ffcc6-c6e3-4385-8ead-bdbbbacf79e9
  • nvd.nist.gov/vuln/detail/CVE-2022-3173

Code Behaviors & Features

Detect and mitigate CVE-2022-3173 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 6.0.10

Fixed versions

  • 6.0.10

Solution

Upgrade to version 6.0.10 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

packagist/snipe/snipe-it/CVE-2022-3173.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:35 +0000.