Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. snipe/snipe-it
  4. ›
  5. CVE-2022-0579

CVE-2022-0579: Improper Privilege Management

February 14, 2022 (updated August 2, 2023)

Improper Privilege Management in Packagist snipe/snipe-it prior to 5.3.9.

References

  • github.com/snipe/snipe-it/commit/db0c0e790892db874573d95f8ae4268b8a011ab1
  • huntr.dev/bounties/70a99cf4-3241-4ffc-b9ed-5c54932f3849
  • nvd.nist.gov/vuln/detail/CVE-2022-0579

Code Behaviors & Features

Detect and mitigate CVE-2022-0579 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.3.9

Fixed versions

  • 5.3.9

Solution

Upgrade to version 5.3.9 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-862: Missing Authorization

Source file

packagist/snipe/snipe-it/CVE-2022-0579.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.