Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. snipe/snipe-it
  4. ›
  5. CVE-2022-0179

CVE-2022-0179: Incorrect Default Permissions

January 12, 2022 (updated June 29, 2023)

snipe-it is vulnerable to Improper Access Control

References

  • github.com/snipe/snipe-it/commit/cf14a0222c67472086cd08b2155f045edaf75f2e
  • huntr.dev/bounties/efdf2ead-f9d1-4767-9f02-d11f762d15e7
  • nvd.nist.gov/vuln/detail/CVE-2022-0179

Code Behaviors & Features

Detect and mitigate CVE-2022-0179 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.3.7

Fixed versions

  • 5.3.7

Solution

Upgrade to version 5.3.7 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-862: Missing Authorization

Source file

packagist/snipe/snipe-it/CVE-2022-0179.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.