Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. simplesamlphp/saml2
  4. ›
  5. CVE-2018-7644

CVE-2018-7644: Improper signature validation

March 5, 2018 (updated October 2, 2019)

The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.

References

  • nvd.nist.gov/vuln/detail/CVE-2018-7644
  • simplesamlphp.org/security/201802-01

Code Behaviors & Features

Detect and mitigate CVE-2018-7644 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.5, all versions starting from 2.0.0 before 2.3.7, all versions starting from 3.0.0 before 3.1.3

Fixed versions

  • 1.10.5
  • 2.3.7
  • 3.1.3

Solution

Upgrade to versions 1.10.5, 2.3.7, 3.1.3 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-347: Improper Verification of Cryptographic Signature

Source file

packagist/simplesamlphp/saml2/CVE-2018-7644.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.