Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. simplesamlphp/saml2
  4. ›
  5. CVE-2018-6519

CVE-2018-6519: Injection Vulnerability

February 1, 2018 (updated October 3, 2018)

The SAML2 library in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

References

  • simplesamlphp.org/security/201801-01

Code Behaviors & Features

Detect and mitigate CVE-2018-6519 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.4, all versions starting from 2.0 before 2.3.5, all versions starting from 3.0 before 3.1.1

Fixed versions

  • 1.10.4
  • 2.3.5
  • 3.1.1

Solution

Upgrade to versions 1.10.4, 2.3.5, 3.1.1 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

Source file

packagist/simplesamlphp/saml2/CVE-2018-6519.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:58 +0000.