Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. silverstripe/framework
  4. ›
  5. GHSA-mqf5-275h-gf6r

GHSA-mqf5-275h-gf6r: Silverstripe framework is vulnerable to XSS in install.php

May 23, 2024

During installation, certain parameters (admin_username and admin_password) are not escaped in the setup form.

This issue is resolved in 3.1.14 stable, although existing users are advised to remove this file prior to deploying to a production server.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2015-016-1.yaml
  • github.com/advisories/GHSA-mqf5-275h-gf6r
  • github.com/silverstripe/silverstripe-framework
  • github.com/silverstripe/silverstripe-framework/commit/4c73721bab0d543eee6137e3c00aa8ec727e95d1
  • www.silverstripe.org/software/download/security-releases/ss-2015-016

Code Behaviors & Features

Detect and mitigate GHSA-mqf5-275h-gf6r with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.1.0 before 3.1.14

Fixed versions

  • 3.1.14

Solution

Upgrade to version 3.1.14 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/silverstripe/framework/GHSA-mqf5-275h-gf6r.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.