Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. silverstripe/admin
  4. ›
  5. CVE-2022-38146

CVE-2022-38146: URL XSS vulnerability due to outdated jquery in CMS

November 21, 2022 (updated April 30, 2025)

Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).

References

  • forum.silverstripe.org/c/releases
  • github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/admin/CVE-2022-38146.yaml
  • github.com/advisories/GHSA-44xv-v98g-v79f
  • nvd.nist.gov/vuln/detail/CVE-2022-38146
  • www.silverstripe.org/blog/tag/release
  • www.silverstripe.org/download/security-releases
  • www.silverstripe.org/download/security-releases/CVE-2022-38146

Code Behaviors & Features

Detect and mitigate CVE-2022-38146 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.0 before 1.11.3

Fixed versions

  • 1.11.3

Solution

Upgrade to version 1.11.3 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/silverstripe/admin/CVE-2022-38146.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:59 +0000.