Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. shopware/platform
  4. ›
  5. CVE-2021-37707

CVE-2021-37707: Improper Input Validation

August 16, 2021 (updated August 24, 2021)

Shopware is an open source eCommerce platform. contain a vulnerability that allows manipulation of product reviews via API. contains a patch. As workarounds for older versions of, corresponding security measures are also available via a plugin.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-37707

Code Behaviors & Features

Detect and mitigate CVE-2021-37707 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 6.1.0 before 6.4.3.1

Fixed versions

  • 6.4.3.1

Solution

Upgrade to version 6.4.3.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Source file

packagist/shopware/platform/CVE-2021-37707.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:36 +0000.