Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. sheng/yiicms
  4. ›
  5. CVE-2020-21246

CVE-2020-21246: YiiCMS Cross Site Scripting vulnerability

June 20, 2023 (updated December 10, 2024)

Cross Site Scripting vulnerability in YiiCMS v.1.2.0 and prior allows a remote attacker to execute arbitrary code via the news function.

References

  • github.com/advisories/GHSA-gqr4-cvf4-3957
  • github.com/yongshengli/yiicms
  • github.com/yongshengli/yiicms/commit/4a9d68564eb78d9f64e3f5dd77186a154093615b
  • github.com/yongshengli/yiicms/issues/6
  • nvd.nist.gov/vuln/detail/CVE-2020-21246

Code Behaviors & Features

Detect and mitigate CVE-2020-21246 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.2.1

Fixed versions

  • 1.2.1

Solution

Upgrade to version 1.2.1 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/sheng/yiicms/CVE-2020-21246.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.