Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. rmccue/requests
  4. ›
  5. CVE-2021-29476

CVE-2021-29476: Deserialization of Untrusted Data

April 29, 2021

Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of Requests 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.

References

  • 2018.zeronights.ru/wp-content/uploads/materials/9%20ZN2018%20WV%20-%20PHP%20unserialize.pdf
  • blog.detectify.com/2019/07/23/improving-wordpress-plugin-security/
  • cdn2.hubspot.net/hubfs/3853213/us-18-Thomas-It%27s-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-....pdf
  • dannewitz.ninja/posts/php-unserialize-object-injection-yet-another-stars-rating-wordpress
  • github.com/FriendsOfPHP/security-advisories/blob/master/rmccue/requests/CVE-2021-29476.yaml
  • github.com/WordPress/Requests/security/advisories/GHSA-52qp-jpq7-6c54
  • github.com/WordPress/wordpress-develop/commit/add6bedf3a53b647d0ebda2970057912d3cd79d3
  • github.com/advisories/GHSA-52qp-jpq7-6c54
  • github.com/ambionics/phpggc/issues/52
  • github.com/rmccue/Requests/pull/421
  • i.blackhat.com/us-18/Thu-August-9/us-18-Thomas-Its-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-Know-It.pdf
  • medium.com/@knownsec404team/extend-the-attack-surface-of-php-deserialization-vulnerability-via-phar-d6455c6a1066
  • nvd.nist.gov/vuln/detail/CVE-2021-29476
  • wordpress.org/news/2020/10/wordpress-5-5-2-security-and-maintenance-release/

Code Behaviors & Features

Detect and mitigate CVE-2021-29476 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.6.0 before 1.8.0

Fixed versions

  • 1.8.0

Solution

Upgrade to version 1.8.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

packagist/rmccue/requests/CVE-2021-29476.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.