Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. prestashop/ps_checkout
  4. ›
  5. CVE-2025-61924

CVE-2025-61924: PrestaShop Checkout Target PayPal merchant account hijacking from backoffice

October 16, 2025

Wrong usage of the PHP array_search() allows bypass of validation.

References

  • github.com/PrestaShopCorp/ps_checkout
  • github.com/PrestaShopCorp/ps_checkout/security/advisories/GHSA-wvpg-4wrh-5889
  • github.com/advisories/GHSA-wvpg-4wrh-5889
  • nvd.nist.gov/vuln/detail/CVE-2025-61924

Code Behaviors & Features

Detect and mitigate CVE-2025-61924 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.4.1, all versions starting from 5.0.0 before 5.0.5

Fixed versions

  • 4.4.1
  • 5.0.5

Solution

Upgrade to versions 4.4.1, 5.0.5 or above.

Impact 3.8 LOW

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-184: Incomplete List of Disallowed Inputs

Source file

packagist/prestashop/ps_checkout/CVE-2025-61924.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:10 +0000.