Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. pocketmine/pocketmine-mp
  4. ›
  5. GHSA-pqp3-8rrw-g8vm

GHSA-pqp3-8rrw-g8vm: PocketMine-MP vulnerable to server crash with certain invalid JSON payloads in `LoginPacket` due to vulnerable dependency

June 6, 2023 (updated May 15, 2024)

An attacker could crash PocketMine-MP by sending malformed JSON in LoginPacket.

This happened due to a bug in netresearch/jsonmapper. The library wasn’t doing proper checks when mapping JSON arrays and objects onto scalar model properties such as strings.

References

  • github.com/advisories/GHSA-pqp3-8rrw-g8vm
  • github.com/cweiske/jsonmapper/pull/210
  • github.com/pmmp/PocketMine-MP
  • github.com/pmmp/PocketMine-MP/commit/09668a37d66c6023685a948b7550c918620e98f2
  • github.com/pmmp/PocketMine-MP/security/advisories/GHSA-pqp3-8rrw-g8vm
  • github.com/pmmp/netresearch-jsonmapper/commit/a31902a31f5b6fdb832f57c0e3a3f16a3b41c012

Code Behaviors & Features

Detect and mitigate GHSA-pqp3-8rrw-g8vm with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.20.5, all versions starting from 4.21.0 before 4.21.1

Fixed versions

  • 4.20.5
  • 4.21.1

Solution

Upgrade to versions 4.20.5, 4.21.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Source file

packagist/pocketmine/pocketmine-mp/GHSA-pqp3-8rrw-g8vm.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:59 +0000.