Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. pimcore/data-importer
  4. ›
  5. GHSA-hq76-662x-7mw4

GHSA-hq76-662x-7mw4: Pimcore includes vulnerable PHPOffice/PhpSpreadsheet

September 3, 2024

Pimcore 10.6.x and Enterprise 10.6.x versions currently depend on PHPOffice/PhpSpreadsheet version 1.x, which has recently been identified with a security vulnerability (CVE-2024-45048). To mitigate this issue, it is recommended to update to the latest version 2.2.2. For more details, please refer to the official advisory: GHSA-ghg6-32f9-2jp7.

References

  • github.com/advisories/GHSA-ghg6-32f9-2jp7
  • github.com/advisories/GHSA-hq76-662x-7mw4
  • github.com/pimcore/pimcore
  • github.com/pimcore/pimcore/security/advisories/GHSA-hq76-662x-7mw4

Code Behaviors & Features

Detect and mitigate GHSA-hq76-662x-7mw4 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.8.9, all versions starting from 1.9.0 before 1.9.3

Fixed versions

  • 1.8.9
  • 1.9.3

Solution

Upgrade to versions 1.8.9, 1.9.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

packagist/pimcore/data-importer/GHSA-hq76-662x-7mw4.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.