Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. phpmyadmin/phpmyadmin
  4. ›
  5. CVE-2018-19969

CVE-2018-19969: Cross-Site Request Forgery (CSRF)

December 11, 2018 (updated April 22, 2019)

By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes.

References

  • www.securityfocus.com/bid/106175
  • nvd.nist.gov/vuln/detail/CVE-2018-19969
  • www.phpmyadmin.net/security/PMASA-2018-7/

Code Behaviors & Features

Detect and mitigate CVE-2018-19969 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.7.0 up to 4.7.6, all versions starting from 4.8.0 before 4.8.4

Fixed versions

  • 4.7.7
  • 4.8.4

Solution

Upgrade to versions 4.7.7, 4.8.4 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

packagist/phpmyadmin/phpmyadmin/CVE-2018-19969.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:59 +0000.