Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. pear/crypt_gpg
  4. ›
  5. CVE-2022-24953

CVE-2022-24953: Improper Input Validation

February 18, 2022 (updated February 26, 2022)

The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.

References

  • github.com/advisories/GHSA-59x4-67mh-px54
  • github.com/pear/Crypt_GPG/commit/29c0fbe96d0d4063ecd5c9a4644cb65a7fb7cc4e
  • github.com/pear/Crypt_GPG/commit/74c8f989cefbe0887274b461dc56197e121bfd04
  • nvd.nist.gov/vuln/detail/CVE-2022-24953

Code Behaviors & Features

Detect and mitigate CVE-2022-24953 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.7

Fixed versions

  • 1.6.7

Solution

Upgrade to version 1.6.7 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

packagist/pear/crypt_gpg/CVE-2022-24953.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:18 +0000.