Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. padraic/humbug_get_contents
  4. ›
  5. CVE-2016-5385

CVE-2016-5385: httpoxy vulnerability

July 18, 2016 (updated March 4, 2019)

humbug_get_contents is affected by httpoxy, a set of vulnerabilities that affect application code running in CGI, or CGI-like environments. If a vulnerable HTTP client makes an outgoing HTTP connection, while running in a server-side CGI application, an attacker may be able to: * Proxy the outgoing HTTP requests made by the web application * Direct the server to open outgoing connections to an address and port of their choosing * Tie up server resources by forcing the vulnerable software to use a malicious proxy

References

  • github.com/humbug/file_get_contents/pull/23
  • github.com/humbug/file_get_contents/pull/23/commits/848e8c282a863654e76bd958acfb57c81cb739b5
  • github.com/humbug/file_get_contents/releases/tag/1.1.2
  • httpoxy.org/

Code Behaviors & Features

Detect and mitigate CVE-2016-5385 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.2

Fixed versions

  • 1.1.2

Solution

Upgrade to version 1.1.2 or above.

Impact 8.1 HIGH

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

packagist/padraic/humbug_get_contents/CVE-2016-5385.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.