Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. openmage/magento-lts
  4. ›
  5. GHSA-gp6m-fq6h-cjcx

GHSA-gp6m-fq6h-cjcx: Magento LTS vulnerable to stored XSS in admin file form

February 27, 2024

Summary

OpenMage is affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields.

Details

Mage_Adminhtml_Block_System_Config_Form_Field_File does not escape filename value in certain situations. Same as: https://nvd.nist.gov/vuln/detail/CVE-2024-20717

PoC

  1. Create empty file with this filename: <img src=x onerror=alert(1)>.crt
  2. Go to System > Configuration > Sales | Payment Methonds.
  3. Click Configure on PayPal Express Checkout.
  4. Choose API Certificate from dropdown API Authentication Methods.
  5. Choose the XSS-file and click Save Config.
  6. Profit, alerts “1” -> XSS.
  7. Reload, alerts “1” -> Stored XSS.

Impact

Affects admins that have access to any fileupload field in admin in core or custom implementations. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

References

  • github.com/OpenMage/magento-lts
  • github.com/OpenMage/magento-lts/security/advisories/GHSA-gp6m-fq6h-cjcx
  • github.com/advisories/GHSA-gp6m-fq6h-cjcx
  • nvd.nist.gov/vuln/detail/CVE-2024-20717

Code Behaviors & Features

Detect and mitigate GHSA-gp6m-fq6h-cjcx with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 20.0.0 before 20.5.0, all versions before 19.5.3

Fixed versions

  • 20.5.0
  • 19.5.3

Solution

Upgrade to version 19.5.3 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/openmage/magento-lts/GHSA-gp6m-fq6h-cjcx.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:07 +0000.