Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. onelogin/php-saml
  4. ›
  5. GHSA-5j8p-438x-rgg5

GHSA-5j8p-438x-rgg5: SAML PHP Toolkit Vulnerability on xmlseclibs CVE-2025-66475

December 9, 2025

Summary

There is a critical vulnerability on xmlseclibs CVE-2025-66475, a dependency of php-saml

Update to the following versions of php-saml which forces the use of patched versions of xmlseclibs:

  • 2.21.1
  • 3.8.1
  • 4.3.1

Impact

Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.

References

  • github.com/SAML-Toolkits/php-saml
  • github.com/SAML-Toolkits/php-saml/releases/tag/2.21.1
  • github.com/SAML-Toolkits/php-saml/releases/tag/3.8.1
  • github.com/SAML-Toolkits/php-saml/releases/tag/4.3.1
  • github.com/SAML-Toolkits/php-saml/security/advisories/GHSA-5j8p-438x-rgg5
  • github.com/advisories/GHSA-5j8p-438x-rgg5
  • github.com/robrichards/xmlseclibs/security/advisories/GHSA-c4cc-x928-vjw9

Code Behaviors & Features

Detect and mitigate GHSA-5j8p-438x-rgg5 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.21.1, all versions starting from 3.0.0 before 3.8.1, all versions starting from 4.0.0 before 4.3.1

Fixed versions

  • 2.21.1
  • 3.8.1
  • 4.3.1

Solution

Upgrade to versions 2.21.1, 3.8.1, 4.3.1 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-1395: Dependency on Vulnerable Third-Party Component

Source file

packagist/onelogin/php-saml/GHSA-5j8p-438x-rgg5.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:06 +0000.