Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. moodle/moodle
  4. ›
  5. CVE-2025-62399

CVE-2025-62399: Moodle vulnerable to brute-force password guesses

October 23, 2025 (updated October 24, 2025)

Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.

References

  • access.redhat.com/security/cve/CVE-2025-62399
  • bugzilla.redhat.com/show_bug.cgi?id=2404432
  • github.com/advisories/GHSA-m58f-9pvv-8mp2
  • github.com/moodle/moodle
  • github.com/moodle/moodle/commit/e4d02567c922c537086de9f59f063ca073552a3a
  • moodle.org/mod/forum/discuss.php?d=470388
  • nvd.nist.gov/vuln/detail/CVE-2025-62399

Code Behaviors & Features

Detect and mitigate CVE-2025-62399 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.21, all versions starting from 4.2.0-beta before 4.4.11, all versions starting from 4.5.0-beta before 4.5.7, all versions starting from 5.0.0-beta before 5.0.3

Fixed versions

  • 5.0.3
  • 4.5.7
  • 4.4.11
  • 4.1.21

Solution

Upgrade to versions 4.1.21, 4.4.11, 4.5.7, 5.0.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-307: Improper Restriction of Excessive Authentication Attempts

Source file

packagist/moodle/moodle/CVE-2025-62399.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:45 +0000.