Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. moodle/moodle
  4. ›
  5. CVE-2024-43430

CVE-2024-43430: Moodle has insufficient access control

November 11, 2024 (updated November 12, 2024)

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

References

  • bugzilla.redhat.com/show_bug.cgi?id=2304258
  • github.com/advisories/GHSA-jpf2-9ppp-2c49
  • github.com/moodle/moodle
  • moodle.org/mod/forum/discuss.php?d=461198
  • nvd.nist.gov/vuln/detail/CVE-2024-43430

Code Behaviors & Features

Detect and mitigate CVE-2024-43430 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.4.0 before 4.4.2

Fixed versions

  • 4.4.2

Solution

Upgrade to version 4.4.2 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-276: Incorrect Default Permissions

Source file

packagist/moodle/moodle/CVE-2024-43430.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.