Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. moodle/moodle
  4. ›
  5. CVE-2024-34002

CVE-2024-34002: Moodle Authenticated LFI risk in some misconfigured shared hosting environments

May 31, 2024 (updated October 31, 2024)

In a shared hosting environment that has been misconfigured to allow access to other users’ content, a Moodle user with both access to restore feedback modules and direct access to the web server outside of the Moodle webroot could execute a local file include.

References

  • github.com/advisories/GHSA-mm9p-xwfm-3fqf
  • github.com/moodle/moodle
  • moodle.org/mod/forum/discuss.php?d=458390
  • nvd.nist.gov/vuln/detail/CVE-2024-34002

Code Behaviors & Features

Detect and mitigate CVE-2024-34002 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.10, all versions starting from 4.2.0 before 4.2.7, all versions starting from 4.3.0 before 4.3.4

Fixed versions

  • 4.3.4
  • 4.2.7
  • 4.1.10

Solution

Upgrade to versions 4.1.10, 4.2.7, 4.3.4 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

packagist/moodle/moodle/CVE-2024-34002.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:47 +0000.