Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. moodle/moodle
  4. ›
  5. CVE-2021-20184

CVE-2021-20184: Improper Validation of Integrity Check Value

January 28, 2021 (updated February 1, 2021)

It was found in Moodle that a insufficient capability checks in some grade related web services meant students were able to view other students grades.

References

  • moodle.org/mod/forum/discuss.php?d=417167
  • nvd.nist.gov/vuln/detail/CVE-2021-20184

Code Behaviors & Features

Detect and mitigate CVE-2021-20184 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.8.7, all versions starting from 3.9.0 before 3.9.4, all versions starting from 3.10.0 before 3.10.1

Fixed versions

  • 3.8.7
  • 3.9.4
  • 3.10.1

Solution

Upgrade to versions 3.8.7, 3.9.4, 3.10.1 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-354: Improper Validation of Integrity Check Value

Source file

packagist/moodle/moodle/CVE-2021-20184.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:26 +0000.