Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. moodle/moodle
  4. ›
  5. CVE-2013-1834

CVE-2013-1834: Moodle allows remote authenticated users to reassign notes

May 13, 2022 (updated January 22, 2024)

notes/edit.php in Moodle 1.9.x through 1.9.19, 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated users to reassign notes via a modified (1) userid or (2) courseid field.

References

  • git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-37411
  • lists.fedoraproject.org/pipermail/package-announce/2013-April/101310.html
  • lists.fedoraproject.org/pipermail/package-announce/2013-April/101358.html
  • openwall.com/lists/oss-security/2013/03/25/2
  • github.com/advisories/GHSA-prrh-679x-79qh
  • github.com/moodle/moodle/commit/1b628c489def6e7394821f53a838591aa392e332
  • github.com/moodle/moodle/commit/646059869e36ea1db844ee0884fb50020348dab1
  • github.com/moodle/moodle/commit/6a9235c998dab2ec0ddc49898a59dd5089156cb0
  • github.com/moodle/moodle/commit/a28da5d9b8221e53d3a0815fd0a1dc27bd48816b
  • github.com/moodle/moodle/commit/bc144ebbe0a78a1ac854454246f26472ba0748b7
  • github.com/moodle/moodle/commit/e13f286026056febba20e931d71134a2d145a091
  • github.com/moodle/moodle/commit/ebfdc35f2a33f14051e22af5410485fe6f1afc92
  • moodle.org/mod/forum/discuss.php?d=225346
  • nvd.nist.gov/vuln/detail/CVE-2013-1834

Code Behaviors & Features

Detect and mitigate CVE-2013-1834 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.9.0 before 2.2.8, all versions starting from 2.3.0 before 2.3.5, all versions starting from 2.4.0 before 2.4.2

Fixed versions

  • 2.2.8
  • 2.3.5
  • 2.4.2

Solution

Upgrade to versions 2.2.8, 2.3.5, 2.4.2 or above.

Impact 4 MEDIUM

AV:N/AC:L/Au:S/C:N/I:P/A:N

Learn more about CVSS

Weakness

  • CWE-264

Source file

packagist/moodle/moodle/CVE-2013-1834.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.