Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. moodle/moodle
  4. ›
  5. CVE-2011-4299

CVE-2011-4299: Moodle vulnerable to Cross-Site Scripting

May 13, 2022 (updated October 31, 2025)

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

References

  • bugzilla.redhat.com/show_bug.cgi?id=747444
  • git.moodle.org/
  • github.com/advisories/GHSA-h6px-pvfh-q2jv
  • nvd.nist.gov/vuln/detail/CVE-2011-4299

Code Behaviors & Features

Detect and mitigate CVE-2011-4299 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0 before 2.0.5, all versions starting from 2.1.0 before 2.1.2

Fixed versions

  • 2.0.5
  • 2.1.2

Solution

Upgrade to versions 2.0.5, 2.1.2 or above.

Impact 4.6 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/moodle/moodle/CVE-2011-4299.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:19 +0000.