Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. modx/revolution
  4. ›
  5. CVE-2017-9070

CVE-2017-9070: MODX Revolution cross-site scripting vulnerability

May 17, 2022 (updated April 22, 2025)

In MODX Revolution before 2.5.7, a user with resource edit permissions can inject an XSS payload into the title of any post via the pagetitle parameter to connectors/index.php.

References

  • citadelo.com/en/2017/04/modx-revolution-cms
  • github.com/advisories/GHSA-7hhg-xj2h-5vq9
  • github.com/modxcms/revolution
  • github.com/modxcms/revolution/pull/13415
  • nvd.nist.gov/vuln/detail/CVE-2017-9070

Code Behaviors & Features

Detect and mitigate CVE-2017-9070 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.5.7

Fixed versions

  • 2.5.7

Solution

Upgrade to version 2.5.7 or above.

Impact 5.4 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/modx/revolution/CVE-2017-9070.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.