Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. microweber/microweber
  4. ›
  5. CVE-2022-0660

CVE-2022-0660: Generation of Error Message Containing Sensitive Information

February 19, 2022 (updated February 26, 2022)

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

References

  • github.com/advisories/GHSA-hhrj-wp42-32v3
  • github.com/microweber/microweber/commit/2417bd2eda2aa2868c1dad1abf62341f22bfc20a
  • huntr.dev/bounties/01fd2e0d-b8cf-487f-a16c-7b088ef3a291
  • nvd.nist.gov/vuln/detail/CVE-2022-0660

Code Behaviors & Features

Detect and mitigate CVE-2022-0660 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.2.11

Fixed versions

  • 1.2.11

Solution

Upgrade to version 1.2.11 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-209: Generation of Error Message Containing Sensitive Information

Source file

packagist/microweber/microweber/CVE-2022-0660.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:06 +0000.