Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. mehrwert/phpmyadmin
  4. ›
  5. CVE-2008-3032

CVE-2008-3032: phpMyAdmin extension for TYPO3 has Cross-site Scripting vulnerability

May 1, 2022 (updated October 31, 2025)

Cross-site scripting (XSS) vulnerability in the phpMyAdmin (phpmyadmin) extension 3.0.1 and earlier for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

References

  • exchange.xforce.ibmcloud.com/vulnerabilities/43508
  • github.com/advisories/GHSA-pm5m-9h5r-xcrg
  • github.com/mehrwert/TYPO3-phpMyAdmin
  • nvd.nist.gov/vuln/detail/CVE-2008-3032
  • web.archive.org/web/20080825005206/http://typo3.org/teams/security/security-bulletins/typo3-20080701-2
  • web.archive.org/web/20200228133438/https://www.securityfocus.com/bid/30039

Code Behaviors & Features

Detect and mitigate CVE-2008-3032 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.2.0

Fixed versions

  • 3.2.0

Solution

Upgrade to version 3.2.0 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/mehrwert/phpmyadmin/CVE-2008-3032.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:36 +0000.