Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. mediawiki/core
  4. ›
  5. CVE-2020-25814

CVE-2020-25814: MediaWiki Cross-site Scripting (XSS) vulnerability

May 24, 2022 (updated May 17, 2024)

In MediaWiki before 1.31.9 and 1.32.x through 1.34.x before 1.34.3, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an tag (or it does not have a href attribute, or it’s empty, etc.). The actual result is that the object contains an <a href =“javascript… that executes when clicked.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2020-25814.yaml
  • github.com/advisories/GHSA-4vr7-m8p8-434h
  • github.com/wikimedia/mediawiki
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RTTPZ7XMDS66I442OLLHXBDNP2LCBJU6
  • lists.wikimedia.org/pipermail/mediawiki-l/2020-September/048480.html
  • lists.wikimedia.org/pipermail/mediawiki-l/2020-September/048488.html
  • nvd.nist.gov/vuln/detail/CVE-2020-25814
  • phabricator.wikimedia.org/T86738
  • www.mediawiki.org/wiki/ResourceLoader/Core_modules

Code Behaviors & Features

Detect and mitigate CVE-2020-25814 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.31.0 before 1.31.9, all versions starting from 1.32.0 before 1.34.3, all versions starting from 1.35.0-rc.0 before 1.35.0

Fixed versions

  • 1.31.9
  • 1.34.3
  • 1.35.0

Solution

Upgrade to versions 1.31.9, 1.34.3, 1.35.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/mediawiki/core/CVE-2020-25814.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:20 +0000.